Jensen Cars & Trucks - Recent Questions, Troubleshooting & Support


Sounds like you need to land the Key On Power to a different point.

Jensen Cars &... | Answered on Sep 11, 2018


Check the ground wire to the radio and speaker because it is probably loose. You may have to solder your connections to the radio and speakers.

Jensen Cars &... | Answered on Jan 03, 2018


ask the parts guy at the dealer for the # and a picture you may be able to make one easy

2003 Jensen SV-8 | Answered on May 09, 2014


You should be using line out from your aftermarket stereo if using the vehicle's existing amp. Then again, you may choose to bypass it, depending on the power being put out by your new stereo.
In both the Expedition and Excursion, the sound systems are different than smaller Fords. The Eddie Bauer typically had the Premium sound system, and the wiring can get tricky with those. You want to make sure it's done right so you don't short out and damage the amp circuit in your new stereo.
If all you're using is the existing speakers, then go ahead and bypass.

Jensen Cars &... | Answered on Feb 14, 2012


Theres a million millimeters in a kilometer. Therefore its 50 million millimeters.

(5^7 for more technical.)

Cars & Trucks | Answered 5 minutes ago


sounds like antitheft issue.
Try this:
1. Disconnect battery.
2. put the key in the ignition and turn it on (like after you have started the car and the engine is running).
3. connect the battery.
4. turn key off and then try to start.

Cars & Trucks | Answered 40 minutes ago

Not finding what you are looking for?
Jensen Logo

16 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Jensen Experts

john h

Level 3 Expert

20245 Answers

Dan Hooper
Dan Hooper

Level 3 Expert

3205 Answers

Robert Wesighan
Robert Wesighan

Level 1 Expert

6 Answers

Are you a Jensen Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...