Question about Kymco 2013 UXV 500 IRS 4x4

1 Answer

Speedometer won't work - Kymco 2013 UXV 500 IRS 4x4

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Kymco Master
  • 9,098 Answers

Kymco MXU 500 Service Repair Manual Download - YouTube

? 0:13
www.youtube.com/watch?v=nqaJ97DMgKY
Dec 31, 2013 - Uploaded by Dermat Colrut
Kymco MXU 500 Factory Service Repair Manual covers all the ...manual,Kymco MXU 500 service repair manual, free KymcoMXU 500 manual ...

Posted on Oct 02, 2015

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Finding the Speed omatder cable on my Suzuki eiger 2005 400 quad because the quad isn't reading my speed


If you have the front wheel off recently one, the speedometer sensor is easily broken and a common occurrence when the wheel is removed and replaced.
The symptoms are erratic or non-working speedo.
Also, there is a wiring harness under the speedometer. Remove the 3 bolts holding on the speedometer, and carefully lift it up and check to make sure the harness is plugged together tightly.

Jan 04, 2018 | Suzuki 2005 Eiger Automatic 400 4X4

1 Answer

I have a arctic cat sport 1000 the speedometer does not work all the time.i no it is electronic but don't no what to check.thanks for any info you may have.kelly


Check to see if the speedometer cable has vibrated loose at the speedometer back. I have seen that a few times.

Nov 29, 2016 | ATVs

1 Answer

570 speedometer stopped working.


Probly broke or sensorbad

Aug 23, 2016 | ATVs

1 Answer

The 4x4 isnt working on my 2010 polaris sportsman 500 ho.


Tony, sounds like a transfer case issue, have machine checked or scanned for error codes.
Check the attached links,Manuals and guides, Good luck with your Bike
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."

ATV TROUBLESHOOTING AND MAINTENANCE
How to Diagnose Motorcycle Electrical Problems Dennis Kirk Inc
Service Manuals for Download in PDF

Mar 04, 2016 | Polaris 2010 Sportsman 500 H.O

1 Answer

My stator is not charging my atv battery, and my speedometer also does not work.


check to see if voltage is coming off the stator while running, AC volatage, from all 3 wires. if thats good you prob need a regulator/rectifier.

Feb 23, 2016 | ATVs

1 Answer

When running my speedometer is dead.


Hi Peter.

Most all speedometers are connected to your transmission by a large-gauge cable that connects to the transmission wall and to the back of your instrument cluster. It has a cable inside that is coupled to the final gear ratio (wheel RPM) and spins with it. The spinning at the other end, turns a magnet that will affect how the speedometer needle rises against a spring. (If it's a digital read-out, never mind, it'll all be data cables and an RPM sensor somewhere). Most likely the cable is broken or detached. Less likely but possible, the gauge itself is broken. They don't tend to be high wear, though all bets are off on an ATV. Look for the cable. make sure it's seated snugly on both ends, and consider replacing it if nothing else works.

Good Luck
D

Nov 30, 2015 | ATVs

1 Answer

My speedodometer stopped working and my engine light is on.


Fix the speedometer and the engine light will probably go away. Also, check any fuses or broken wires.

Sep 21, 2013 | ATVs

Not finding what you are looking for?
Kymco 2013 UXV 500 IRS 4x4 Logo

1,222 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kymco ATVs Experts

Marvin
Marvin

Level 3 Expert

85020 Answers

 Scott Tx
Scott Tx

Level 2 Expert

604 Answers

john h

Level 3 Expert

21157 Answers

Are you a Kymco ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...