Kymco 2010 MXU 375 IRS 4x4 - Answered Questions & Fixed issues


Hi Shannon:
Possibles:
- Needle valve has been compromised, possibly held open with grit.
Carefully dismantle and blow out all orifices with compressed air.
- Float level set too high. Review the way the float shutoff mechanism works. Make sure the float moves up and down easily and that it still floats as intended. Double check the lever that moves the needle valve. Make sure it is correctly connected to the needle.
Reply as a COMMENT to this post to let me know what you find.
Cheers.

Kymco 2010 MXU... | Answered on Feb 22, 2016 | 337 views


Any answers yet?? Im having the same problem

Kymco 2010 MXU... | Answered on Aug 31, 2015 | 356 views


fuse link should be in the battery cable it's self

Kymco 2010 MXU... | Answered on Dec 15, 2013 | 475 views


do you have internet where you live? Try this
"2002 Polaris trailblazer users manual"

ATVs | Answered Yesterday | 44 views


Yea, what you said == just google it.

ATVs | Answered Yesterday | 22 views


Usually, there is a hole plug near the bottom of the casing. BUT first drive it around a lot cause gear oil is heavy and it won't come out very fast if it is cold.

ATVs | Answered Yesterday | 32 views


power to efi module? no, find where it stopped and reconnect.
yes, power out of efi module? no, replace efi module.
yes, open between efi and pump.

ATVs | Answered 2 days ago | 27 views


search engine are more efficient. If this isn't to your liking
https://taotao.zendesk.com/hc/en-us/articles/204167645-General-Torque-Spec-Settings-
try searching "clutch nut torque spec"

ATVs | Answered 2 days ago | 15 views


I don't understand your problem. What is a "make end"?

ATVs | Answered 2 days ago | 13 views


are you into troubleshooting? Probably not, but one must have fuel, ignition, and air to make things burn or run an ICE.
What don't you have?
Is there an ignition source? Did you pull the spark plug and verify it will spark?
Is there fuel? No, not in the tank, it must be getting to the engine.
Is the spark plug wet? If it isn't wet with fuel, you are not getting fuel.
Is there air? No, not what you are breathing, but getting to the carburetor. Did you check the air cleaner?

ATVs | Answered 2 days ago | 15 views


It acts like you have burnt spots on the starter shaft that touches the brushes ( voltage) to start. When you rock the vehicle in gear the starter shaft moves and it is placed in a position where the brushes can make a clean contact. Then when you turn the key, the starter will engage and the vehicle will start. My recommendation would be to change out the starter.

ATVs | Answered 3 days ago | 42 views


check wire harness for short

ATVs | Answered on Oct 10, 2019 | 36 views


It sounds as though your ignition switch is not hooked up correctly. Follow the harness from the ignition switch to the bullet connectors under the front body plastic. Make sure the colors all match up.

ATVs | Answered on Oct 08, 2019 | 28 views


Even though the overflow is full, the radiator could be empty. You need to remove the radiator cap and make sure it is full to the top. If you find the fluid level is low in the radiator, that would indicate there is a leak in the hose between the radiator and the overflow tank.

ATVs | Answered on Oct 08, 2019 | 31 views


If you bypass unit will not run

ATVs | Answered on Oct 03, 2019 | 32 views


Check rear drive shaft from engine to rear differential.

ATVs | Answered on Oct 03, 2019 | 29 views


Verify spark and fuel.

ATVs | Answered on Oct 03, 2019 | 23 views

Not finding what you are looking for?
Kymco 2010 MXU 375 IRS 4x4 Logo

7 questions posted

Ask a Question

Usually answered in minutes!

Top Kymco ATVs Experts

Marvin
Marvin

Level 3 Expert

85206 Answers

 Scott Tx
Scott Tx

Level 2 Expert

604 Answers

john h

Level 3 Expert

22408 Answers

Are you a Kymco ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...